Expérience vécue et réponse difficile à trouver pour cette alerte lors du téléversement d’un élément dans la médiathèque de WordPress….
« Le serveur a renvoyé une réponse inattendue. Cependant, le fichier a peut-être été bien téléversé. Veuillez vérifier dans la médiathèque ou actualiser »
De mon côté, la réponse se trouvait du côté de WP-Optimize qui générait cette erreur, bien que les images étaient quand même ajoutées à ma médiathèque.
Il faut donc aller regarder du côté de la compressions des images qui « bloque » (ralenti) le processus d’importation des images.
Si vous n’avez pas WP-Optimize, il est possible que vous ayez installé un autre plugin qui s’occupe de la compression des images et qui utilise des API tierces comme « Smush.it » ou « resmush.it ».
Solution : désactiver la compression des images et faire remonter votre message d’erreur aux propriétaires du plugin que vous utilisez et qui est la cause de cette alerte.
PS : le message d’erreur est généré parce que le fichier part en compression avant d’être stocké dans votre dossier média. WordPress attend un fichier qui est déclaré dans la BDD et qui n’est pas là.